aboutsummaryrefslogtreecommitdiffstats
path: root/src/intel/compiler/meson.build
diff options
context:
space:
mode:
authorFrancisco Jerez <[email protected]>2018-06-11 12:54:17 -0700
committerFrancisco Jerez <[email protected]>2019-10-11 12:24:16 -0700
commit25dd67099df301f09ce40b8f9c5a3bbc857e367c (patch)
tree857fbb0010ea87f081ac5e42b2dce90f2b87ad73 /src/intel/compiler/meson.build
parent51dc40cefb0b04726668bb3f3ee0e51cdaf30d72 (diff)
intel/eu: Rework opcode description tables to allow efficient look-up by either HW or IR opcode.
This rewrites the current opcode description tables as a more compact flat data structure. The purpose is to allow efficient constant-time look-up by either HW or IR opcode, which will allow us to drop the hard-coded correspondence between HW and IR opcodes -- See the next commits for the rationale. brw_eu.c is now built as C++ source so we can take advantage of pointers to member in order to make the look-up function work regardless of the opcode_desc member used as look-up key. v2: Optimize devinfo struct comparison (Caio) Reviewed-by: Caio Marcelo de Oliveira Filho <[email protected]> Reviewed-by: Jordan Justen <[email protected]> Reviewed-by: Kenneth Graunke <[email protected]>
Diffstat (limited to 'src/intel/compiler/meson.build')
-rw-r--r--src/intel/compiler/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/intel/compiler/meson.build b/src/intel/compiler/meson.build
index 798163ecd2d..d74caa0632b 100644
--- a/src/intel/compiler/meson.build
+++ b/src/intel/compiler/meson.build
@@ -37,7 +37,7 @@ libintel_compiler_files = files(
'brw_disasm.c',
'brw_disasm_info.c',
'brw_disasm_info.h',
- 'brw_eu.c',
+ 'brw_eu.cpp',
'brw_eu_compact.c',
'brw_eu_defines.h',
'brw_eu_emit.c',