aboutsummaryrefslogtreecommitdiffstats
path: root/src/intel/Makefile.am
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-11-09 13:49:52 -0800
committerDylan Baker <[email protected]>2017-11-10 09:41:55 -0800
commit854455498c0370e959c0bb25680641e05faea3e2 (patch)
tree0c4ad5423784e70f3bd704e378e92d9acb9927be /src/intel/Makefile.am
parentb8c85f5accad78d62476a02f0dc5eb64953998d7 (diff)
autotools: Set C++ visibility flags on Intel
These flags are set for C sources, but not C++. This causes symbol visibility leaks from the C++ parts of the Intel compiler. Fixes: 700bebb958e93f4d ("i965: Move the back-end compiler to src/intel/compiler") Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Matt Turner <[email protected]>
Diffstat (limited to 'src/intel/Makefile.am')
-rw-r--r--src/intel/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/intel/Makefile.am b/src/intel/Makefile.am
index a34e3014497..6a5e393f175 100644
--- a/src/intel/Makefile.am
+++ b/src/intel/Makefile.am
@@ -46,6 +46,9 @@ AM_CFLAGS = \
$(VISIBILITY_CFLAGS) \
$(WNO_OVERRIDE_INIT)
+AM_CXXFLAGS = \
+ $(VISIBILITY_CXXFLAGS)
+
MKDIR_GEN = $(AM_V_at)$(MKDIR_P) $(@D)
PYTHON_GEN = $(AM_V_GEN)$(PYTHON2) $(PYTHON_FLAGS)