aboutsummaryrefslogtreecommitdiffstats
path: root/src/glx/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2019-07-01 10:04:03 -0700
committerDylan Baker <[email protected]>2019-07-23 15:34:23 -0700
commit7cf50af6f512024331d766832e0cc20a6a4499d7 (patch)
tree628458f7434b520aa5f02fff13b984a54577c9c4 /src/glx/meson.build
parent3d6cffffcf41349ff5db332a4662adb49d842a3a (diff)
meson: allow building all glx without any drivers
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=111016 Fixes: a47c525f3281a2753180e076c7e9b7772aff8f06 ("meson: build glx") Acked-by: Emil Velikov <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'src/glx/meson.build')
-rw-r--r--src/glx/meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/glx/meson.build b/src/glx/meson.build
index 0e3245a254f..d7b4d086642 100644
--- a/src/glx/meson.build
+++ b/src/glx/meson.build
@@ -1,4 +1,4 @@
-# Copyright © 2017 Intel Corporation
+# Copyright © 2017-2019 Intel Corporation
# Permission is hereby granted, free of charge, to any person obtaining a copy
# of this software and associated documentation files (the "Software"), to deal
@@ -70,7 +70,7 @@ extra_libs_libglx = []
extra_deps_libgl = []
extra_ld_args_libgl = []
-if with_dri
+if with_glx == 'dri'
files_libglx += files(
'dri_common.c',
'dri_common.h',
@@ -83,7 +83,7 @@ if with_dri
endif
# dri2
-if with_dri and with_dri_platform == 'drm' and dep_libdrm.found()
+if with_glx == 'dri' and with_dri_platform == 'drm' and dep_libdrm.found()
files_libglx += files(
'dri2.c',
'dri2_glx.c',