aboutsummaryrefslogtreecommitdiffstats
path: root/src/glx/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2018-02-23 19:32:00 +0000
committerEmil Velikov <[email protected]>2018-08-08 13:37:09 +0100
commita7ea7511ba76c0a83eec84dfc9c14c82b5c82dc4 (patch)
tree19088a1786072c90072306349a4df00f4591ea29 /src/glx/Makefile.am
parent834036500c1b4fcc5550ff5d4ccabc872e5a868c (diff)
automake: require shared glapi when using DRI based libGL
This has been a requirement for ages, yet it seems like we never explicitly errored out during configure. CC: <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Adam Jackson <[email protected]>
Diffstat (limited to 'src/glx/Makefile.am')
-rw-r--r--src/glx/Makefile.am5
1 files changed, 1 insertions, 4 deletions
diff --git a/src/glx/Makefile.am b/src/glx/Makefile.am
index 5233257fb40..8f9d80c9f41 100644
--- a/src/glx/Makefile.am
+++ b/src/glx/Makefile.am
@@ -19,9 +19,6 @@
# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
# IN THE SOFTWARE.
-if HAVE_SHARED_GLAPI
-SHARED_GLAPI_LIB = $(top_builddir)/src/mapi/shared-glapi/libglapi.la
-endif
SUBDIRS =
@@ -181,7 +178,7 @@ GL_LIBS = \
$(LIBDRM_LIBS) \
libglx.la \
$(top_builddir)/src/mapi/glapi/libglapi.la \
- $(SHARED_GLAPI_LIB) \
+ $(top_builddir)/src/mapi/shared-glapi/libglapi.la \
$(GL_LIB_DEPS)
GL_LDFLAGS = \