aboutsummaryrefslogtreecommitdiffstats
path: root/src/glsl/Makefile.am
diff options
context:
space:
mode:
authorKristian Høgsberg Kristensen <[email protected]>2016-01-08 15:23:56 -0800
committerKristian Høgsberg Kristensen <[email protected]>2016-01-08 16:15:49 -0800
commit81f7fd3c54fa231081ceaf6e17af23e34a786c58 (patch)
tree241f5b9734fcc76afc597219dbbdb44380503005 /src/glsl/Makefile.am
parente3706a7118cb572077c877b92450dc955e7a6754 (diff)
glsl: Don't add nir files to libglsl_la_SOURCES
SCons doesn't understand nir yet and doesn't want to compile the glsl to nir pass. Move the files to their own variable so we can add it only for automake. Tested-by: Brian Paul <[email protected]>
Diffstat (limited to 'src/glsl/Makefile.am')
-rw-r--r--src/glsl/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/glsl/Makefile.am b/src/glsl/Makefile.am
index 33a34e4ccc8..95efdb327c1 100644
--- a/src/glsl/Makefile.am
+++ b/src/glsl/Makefile.am
@@ -144,8 +144,8 @@ libglsl_la_SOURCES = \
glsl_parser.h \
$(LIBGLSL_FILES) \
$(NIR_FILES) \
- $(NIR_GENERATED_FILES)
-
+ $(NIR_GENERATED_FILES) \
+ $(GLSL_TO_NIR_FILES)
libnir_la_SOURCES = \
$(NIR_FILES) \