aboutsummaryrefslogtreecommitdiffstats
path: root/src/gbm/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-01-11 02:50:08 +0000
committerEmil Velikov <[email protected]>2014-01-18 18:47:48 +0000
commitfae0dfa59b3111fecc7b8de8493eaaee165a102a (patch)
tree183ecfff9509225819f8a5e2422092d4d2012feb /src/gbm/Makefile.am
parenteac776cf779b705cbfb8d41812f1d171fb09c76f (diff)
gbm: use the loader util lib
Additionally this commit removes the following exported functions _gbm_udev_device_new_from_fd() _gbm_fd_get_device_name() _gbm_log() All three were erroneously marked as exported since their inception. Neither of them has ever been a part of the API thus there should be no users of them. Cc: Chad Versace <[email protected]> Cc: Kristian Høgsberg <[email protected]> Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Rob Clark <[email protected]> Reviewed-by: Kristian Høgsberg <[email protected]> Reviewed-by: Ian Romanick <[email protected]>
Diffstat (limited to 'src/gbm/Makefile.am')
-rw-r--r--src/gbm/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/src/gbm/Makefile.am b/src/gbm/Makefile.am
index 5ae7a682474..4030cc6f4a5 100644
--- a/src/gbm/Makefile.am
+++ b/src/gbm/Makefile.am
@@ -19,10 +19,10 @@ include_HEADERS = main/gbm.h
libgbm_la_SOURCES = \
main/gbm.c \
- main/backend.c \
- main/common.c
+ main/backend.c
libgbm_la_LDFLAGS = -version-info 1:0
libgbm_la_LIBADD = \
+ $(top_builddir)/src/loader/libloader.la \
$(LIBUDEV_LIBS) \
$(LIBKMS_LIBS) \
$(DLOPEN_LIBS)
@@ -36,8 +36,7 @@ endif
if HAVE_DRI
noinst_LTLIBRARIES = libgbm_dri.la
libgbm_dri_la_SOURCES = \
- backends/dri/gbm_dri.c \
- backends/dri/driver_name.c
+ backends/dri/gbm_dri.c
libgbm_dri_la_CFLAGS = \
$(AM_CFLAGS) \