aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/vdpau/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2015-11-20 18:02:12 +0000
committerEmil Velikov <[email protected]>2015-11-21 12:52:20 +0000
commit1eb6e8a23cc29081105336dc2a1cbf6bb4c2603d (patch)
tree3b82be43b9e6d76e831cf5dfb1aa80f2b8c394a3 /src/gallium/targets/vdpau/Makefile.am
parent23fb11455b415238fb9e378fa0ab51f4b6cefd7a (diff)
{auxiliary,targets}/vl: use static/dynamic pipe-loader
Analogous to previous commit. v2: rebase on top of vl_winsys_drm.c addition Signed-off-by: Emil Velikov <[email protected]> Acked-by: Rob Clark <[email protected]>
Diffstat (limited to 'src/gallium/targets/vdpau/Makefile.am')
-rw-r--r--src/gallium/targets/vdpau/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/gallium/targets/vdpau/Makefile.am b/src/gallium/targets/vdpau/Makefile.am
index f9fb56069a9..d388f8b5014 100644
--- a/src/gallium/targets/vdpau/Makefile.am
+++ b/src/gallium/targets/vdpau/Makefile.am
@@ -47,7 +47,7 @@ EXTRA_DIST = \
TARGET_DRIVERS =
TARGET_CPPFLAGS =
-TARGET_LIB_DEPS = $(top_builddir)/src/loader/libloader.la
+TARGET_LIB_DEPS =
include $(top_srcdir)/src/gallium/drivers/nouveau/Automake.inc
@@ -59,7 +59,10 @@ if HAVE_GALLIUM_STATIC_TARGETS
libvdpau_gallium_la_SOURCES += target.c
libvdpau_gallium_la_CPPFLAGS = $(TARGET_CPPFLAGS)
-libvdpau_gallium_la_LIBADD += $(TARGET_LIB_DEPS) \
+libvdpau_gallium_la_LIBADD += \
+ $(top_builddir)/src/gallium/auxiliary/pipe-loader/libpipe_loader_static.la \
+ $(GALLIUM_PIPE_LOADER_WINSYS_LIBS) \
+ $(TARGET_LIB_DEPS) \
$(TARGET_RADEON_WINSYS) $(TARGET_RADEON_COMMON)
else # HAVE_GALLIUM_STATIC_TARGETS