aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/targets/opencl/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-03-11 15:24:07 +0000
committerEmil Velikov <[email protected]>2014-03-31 12:26:47 +0100
commit0484b8446a02a4b77d5a1dab89f6e0b8af831027 (patch)
tree044c399c8d86c9e59e138785a2b4a2646064d879 /src/gallium/targets/opencl/Makefile.am
parent2d9c33009a62b704e64b49b87ed1cee9c8dcb12b (diff)
gallium/targets: explicitly include a dummy.cpp and remove all the LINK mayhem
Explicitly setting the linker variable was required for old and broken build toolchains. At this point this should no longer be needed, and setting the sources lists will trigger generation of the correct LINK variables. Explicitly include dummy.cpp to use g++ to link the static library which in most cases is based upon C++ code. v2: Reword commit message. Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Matt Turner <[email protected]>
Diffstat (limited to 'src/gallium/targets/opencl/Makefile.am')
-rw-r--r--src/gallium/targets/opencl/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/gallium/targets/opencl/Makefile.am b/src/gallium/targets/opencl/Makefile.am
index 20a52476842..eb25a5e47aa 100644
--- a/src/gallium/targets/opencl/Makefile.am
+++ b/src/gallium/targets/opencl/Makefile.am
@@ -41,10 +41,9 @@ lib@OPENCL_LIBNAME@_la_LIBADD += \
$(LIBDRM_LIBS)
endif
+nodist_EXTRA_lib@OPENCL_LIBNAME@_la_SOURCES = dummy.cpp
lib@OPENCL_LIBNAME@_la_SOURCES =
-# Force usage of a C++ linker
-nodist_EXTRA_lib@OPENCL_LIBNAME@_la_SOURCES = dummy.cpp
if HAVE_CLOVER_ICD
icddir = /etc/OpenCL/vendors/