aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/state_trackers/omx/bellagio/Makefile.am
diff options
context:
space:
mode:
authorGurkirpal Singh <[email protected]>2018-01-20 05:12:06 +0530
committerJulien Isorce <[email protected]>2018-03-06 13:07:03 +0000
commitbb5e27fab6087a5c1528a5faf507acce700e883c (patch)
tree8c0bff83d1c599b20d75a62b998255615ae435ea /src/gallium/state_trackers/omx/bellagio/Makefile.am
parente96e6f60f705c04a3d437eea9fe308826b494c67 (diff)
st/omx/bellagio: Rename st and target directories
v2: Refactor out screen functions to st/omx Allows to keep all the code under st/omx (st/omx/tizonia and st/omx/bellagio). Reverts targets/omx_bellagio to omx as additions to existing files is enough to compile for both bellagio and tizonia. * autotools changes: --enable-omx -> --enable-omx-bellagio * meson changes: -Dgallium-omx=false -> -Dgallium-omx=disabled -Dgallium-omx=true -> -Dgallium-omx=bellagio Acked-by: Leo Liu <[email protected]> Reviewed-by: Julien Isorce <[email protected]>
Diffstat (limited to 'src/gallium/state_trackers/omx/bellagio/Makefile.am')
-rw-r--r--src/gallium/state_trackers/omx/bellagio/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/gallium/state_trackers/omx/bellagio/Makefile.am b/src/gallium/state_trackers/omx/bellagio/Makefile.am
new file mode 100644
index 00000000000..3e542ab0f26
--- /dev/null
+++ b/src/gallium/state_trackers/omx/bellagio/Makefile.am
@@ -0,0 +1,36 @@
+# Copyright © 2012 Intel Corporation
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+# HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+# WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+# DEALINGS IN THE SOFTWARE.
+
+include Makefile.sources
+include $(top_srcdir)/src/gallium/Automake.inc
+
+AM_CFLAGS = \
+ -I$(top_srcdir)/src/gallium/state_trackers/omx \
+ $(GALLIUM_CFLAGS) \
+ $(VISIBILITY_CFLAGS) \
+ $(VL_CFLAGS) \
+ $(XCB_DRI3_CFLAGS) \
+ $(OMX_BELLAGIO_CFLAGS)
+
+noinst_LTLIBRARIES = libomxtracker.la
+
+libomxtracker_la_SOURCES = $(C_SOURCES)