aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/state_trackers/clover/meson.build
diff options
context:
space:
mode:
authorPierre Moreau <[email protected]>2018-02-10 21:40:10 +0100
committerKarol Herbst <[email protected]>2019-09-21 08:28:32 +0000
commit939a7e9a5c0a74fb2fabb00b61ba6375e22bf1a6 (patch)
tree07b88b19e373213f48f5e0f7c2665fb5f7a542d4 /src/gallium/state_trackers/clover/meson.build
parent866f6f11d928e6e9b1a45468ec9d6cf12b7f2778 (diff)
clover/spirv: Add functions for validating SPIR-V binaries
Changes since: * v12: - remove autotools (Karol Herbst) - Remove the callback in format_validation_msg. (Francisco Jerez) - Removed is_binary_spirv. (Francisco Jerez) - Pass a string reference to is_valid_spirv instead of the notification callback. (Francisco Jerez) * v11: Fix compilation error introduced in v11. * v10: - Reuse format_validation_msg in is_valid_spirv. - Remove LVL2STR macro in format_validation_msg. * v9: Add `clover_cpp_std` to the overrides of the `libclspirv` target in Meson. * v7: Add DEFINES to libclspirv and libclover, in autotools, as they would otherwise never know whether CLOVER_ALLOW_SPIRV has been defined (Dave Airlie) * v6: Update the dependency name (meson) and the libs variable (Makefile) due to the replacement of llvm-spirv to the new official SPIRV-LLVM-Translator. * v5: Changed to match the updated “clover/llvm: Allow translating from SPIR-V to LLVM IR” in the v6. Reviewed-by: Karol Herbst <[email protected]> Reviewed-by: Francisco Jerez <[email protected]>
Diffstat (limited to 'src/gallium/state_trackers/clover/meson.build')
-rw-r--r--src/gallium/state_trackers/clover/meson.build11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/gallium/state_trackers/clover/meson.build b/src/gallium/state_trackers/clover/meson.build
index 9e3ec8d5ad4..0d8e0675eb9 100644
--- a/src/gallium/state_trackers/clover/meson.build
+++ b/src/gallium/state_trackers/clover/meson.build
@@ -57,6 +57,15 @@ libclllvm = static_library(
override_options : clover_cpp_std,
)
+libclspirv = static_library(
+ 'clspirv',
+ files('spirv/invocation.cpp', 'spirv/invocation.hpp'),
+ include_directories : clover_incs,
+ cpp_args : [clover_spirv_cpp_args, cpp_vis_args],
+ dependencies : [dep_spirv_tools],
+ override_options : clover_cpp_std,
+)
+
clover_files = files(
'api/context.cpp',
'api/device.cpp',
@@ -117,6 +126,6 @@ libclover = static_library(
[clover_files, sha1_h],
include_directories : clover_incs,
cpp_args : [clover_spirv_cpp_args, clover_cpp_args, cpp_vis_args],
- link_with : [libclllvm],
+ link_with : [libclllvm, libclspirv],
override_options : clover_cpp_std,
)