aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/state_trackers/clover/meson.build
diff options
context:
space:
mode:
authorPierre Moreau <[email protected]>2018-02-10 16:56:11 +0100
committerKarol Herbst <[email protected]>2019-02-26 21:02:07 +0100
commit67769c913f2e1608530779be207bcb1eb46f3a90 (patch)
treef9f68a397aedf66ae19592a6597d610ac5039e1b /src/gallium/state_trackers/clover/meson.build
parent669d00ba4cabf444de12eb3663c5251b519e1681 (diff)
clover: Remove the TGSI backend as unused
Reviewed-by: Karol Herbst <[email protected]> Reviewed-by: Francisco Jerez <[email protected]>
Diffstat (limited to 'src/gallium/state_trackers/clover/meson.build')
-rw-r--r--src/gallium/state_trackers/clover/meson.build10
1 files changed, 1 insertions, 9 deletions
diff --git a/src/gallium/state_trackers/clover/meson.build b/src/gallium/state_trackers/clover/meson.build
index 62ac5f5278d..2ff060bf35b 100644
--- a/src/gallium/state_trackers/clover/meson.build
+++ b/src/gallium/state_trackers/clover/meson.build
@@ -25,14 +25,6 @@ if with_opencl_icd
clover_cpp_args += '-DHAVE_CLOVER_ICD'
endif
-libcltgsi = static_library(
- 'cltgsi',
- files('tgsi/compiler.cpp', 'tgsi/invocation.hpp'),
- include_directories : clover_incs,
- cpp_args : [cpp_vis_args],
- override_options : clover_cpp_std,
-)
-
libclllvm = static_library(
'clllvm',
files(
@@ -120,6 +112,6 @@ libclover = static_library(
[clover_files, sha1_h],
include_directories : clover_incs,
cpp_args : [clover_cpp_args, cpp_vis_args],
- link_with : [libcltgsi, libclllvm],
+ link_with : [libclllvm],
override_options : clover_cpp_std,
)