aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2018-04-13 15:05:55 -0700
committerDylan Baker <[email protected]>2018-04-24 14:08:15 -0700
commit5a670d08c02c2fdfd8eb57914939045c1bdfb9b4 (patch)
tree194c0b37b6ac28914b8a22680ebb5f84ec190b47 /src/gallium/meson.build
parent1546f76a39f0539821dd9bb4706576730e864fd2 (diff)
meson: raise required version to 0.44.1
We have already required 0.44 for building clover and swr, so it was already partially required. This just makes it required across the board instead of just for clover and swr. There is a bug in 0.44 which makes it impossible to build mesa in some configurations, so require 0.44.1 which fixes this. Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'src/gallium/meson.build')
-rw-r--r--src/gallium/meson.build6
1 files changed, 0 insertions, 6 deletions
diff --git a/src/gallium/meson.build b/src/gallium/meson.build
index 02391728d30..720f3731879 100644
--- a/src/gallium/meson.build
+++ b/src/gallium/meson.build
@@ -40,9 +40,6 @@ if with_platform_haiku
subdir('winsys/sw/hgl')
endif
if with_gallium_swr
- if meson.version().version_compare('< 0.44.0')
- error('SWR requires meson 0.44.0 or greater.')
- endif
subdir('drivers/swr')
else
driver_swr = declare_dependency()
@@ -144,9 +141,6 @@ if with_gallium_opencl
# consumer
subdir('targets/pipe-loader')
- if meson.version().version_compare('< 0.44.0')
- error('OpenCL requires meson 0.44.0 or greater.')
- endif
subdir('state_trackers/clover')
subdir('targets/opencl')
endif