aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-10-26 15:45:40 -0700
committerDylan Baker <[email protected]>2017-11-28 14:06:38 -0800
commit43b0e5f5cd87b3ca4dc97a6373cbee1f1f129f06 (patch)
tree47ca49cc9047109bcd390480d6ec26dd680dd373 /src/gallium/meson.build
parenta537231b226280bc1e5b7f0f58707cbd2cf29848 (diff)
meson: build virgl driver
Build tested only. Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'src/gallium/meson.build')
-rw-r--r--src/gallium/meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/gallium/meson.build b/src/gallium/meson.build
index 6fe7f15da03..8e60c7f3288 100644
--- a/src/gallium/meson.build
+++ b/src/gallium/meson.build
@@ -1,4 +1,5 @@
# Copyright © 2017 Dylan Baker
+# Copyright © 2017 Intel Corporation
# Permission is hereby granted, free of charge, to any person obtaining a copy
# of this software and associated documentation files (the "Software"), to deal
@@ -85,6 +86,11 @@ if with_gallium_svga
subdir('drivers/svga')
subdir('winsys/svga/drm')
endif
+if with_gallium_virgl
+ subdir('drivers/virgl')
+ subdir('winsys/virgl/drm')
+ subdir('winsys/virgl/vtest')
+endif
if with_dri
subdir('state_trackers/dri')
endif
@@ -96,7 +102,6 @@ if with_glx == 'gallium-xlib'
subdir('state_trackers/glx/xlib')
endif
# TODO: SWR
-# TODO: virgl
# TODO: clover
if with_dri
subdir('targets/dri')