aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/radeonsi/meson.build
diff options
context:
space:
mode:
authorMathieu Bridon <[email protected]>2018-08-09 10:27:26 +0200
committerDylan Baker <[email protected]>2018-08-10 15:15:09 -0700
commit2ee1c86d71bee5ddca2c8795b4d343e31d28df99 (patch)
tree434ff307fe52734f62ae83427accc863cb455778 /src/gallium/drivers/radeonsi/meson.build
parentbd27203f4d808763ac24ac94eb677cacf3e7cb99 (diff)
meson: Build with Python 3
Now that all the build scripts are compatible with both Python 2 and 3, we can flip the switch and tell Meson to use the latter. Since Meson already depends on Python 3 anyway, this means we don't need two different Python stacks to build Mesa. Signed-off-by: Mathieu Bridon <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/gallium/drivers/radeonsi/meson.build')
-rw-r--r--src/gallium/drivers/radeonsi/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/gallium/drivers/radeonsi/meson.build b/src/gallium/drivers/radeonsi/meson.build
index 9e249adc61e..f943b61ebff 100644
--- a/src/gallium/drivers/radeonsi/meson.build
+++ b/src/gallium/drivers/radeonsi/meson.build
@@ -91,7 +91,7 @@ si_driinfo_h = custom_target(
'../../auxiliary/pipe-loader/driinfo_gallium.h', 'driinfo_radeonsi.h'
),
output : 'si_driinfo.h',
- command : [prog_python2, '@INPUT@'],
+ command : [prog_python, '@INPUT@'],
capture : true,
)