aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/radeon/Makefile.am
diff options
context:
space:
mode:
authorTom Stellard <[email protected]>2012-08-30 12:55:29 -0400
committerAndreas Boll <[email protected]>2013-01-10 22:01:08 +0100
commit0dcb9ae0d9366b2ca9520c0c820cc466eb35bf67 (patch)
treeda9142dcbd68abc75296bc2c28e2f49bd700a34b /src/gallium/drivers/radeon/Makefile.am
parent2cbb94b3ce012a2caf9e6ab10d69bf85d7222c27 (diff)
radeon/llvm: Convert to Automake
v2: Johannes Obermayr <[email protected]> Fix some undefined symbols. v3: Johannes Obermayr <[email protected]> Build it -shared to fix egl_gallium.so on r600/radeonsi builds.
Diffstat (limited to 'src/gallium/drivers/radeon/Makefile.am')
-rw-r--r--src/gallium/drivers/radeon/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/gallium/drivers/radeon/Makefile.am b/src/gallium/drivers/radeon/Makefile.am
new file mode 100644
index 00000000000..091adc4016d
--- /dev/null
+++ b/src/gallium/drivers/radeon/Makefile.am
@@ -0,0 +1,31 @@
+include Makefile.sources
+include $(top_srcdir)/src/gallium/Automake.inc
+
+if HAVE_GALLIUM_R600
+if HAVE_GALLIUM_RADEONSI
+lib_LTLIBRARIES = libllvmradeon@[email protected]
+libllvmradeon@VERSION@_la_LDFLAGS = -Wl,--no-undefined -shared -avoid-version \
+ $(LLVM_LDFLAGS)
+else
+noinst_LTLIBRARIES = libllvmradeon@[email protected]
+endif
+else
+noinst_LTLIBRARIES = libllvmradeon@[email protected]
+endif
+
+AM_CXXFLAGS = \
+ $(filter-out -DDEBUG, $(LLVM_CXXFLAGS)) \
+ $(DEFINES)
+
+AM_CFLAGS = \
+ $(GALLIUM_CFLAGS) \
+ $(LLVM_CFLAGS)
+
+libllvmradeon@VERSION@_la_SOURCES = \
+ $(CPP_FILES) \
+ $(C_FILES)
+
+libllvmradeon@VERSION@_la_LIBADD = \
+ $(top_builddir)/src/gallium/auxiliary/libgallium.la \
+ $(CLOCK_LIB) \
+ $(LLVM_LIBS)