aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/r600/Makefile.am
diff options
context:
space:
mode:
authorVadim Girlin <[email protected]>2013-04-30 20:53:15 +0400
committerVadim Girlin <[email protected]>2013-04-30 21:50:47 +0400
commitad1df471d083630106da8c39ec076f49e779e965 (patch)
tree2f4f7031acc3b6227f05edc0b44ea3575d5c555d /src/gallium/drivers/r600/Makefile.am
parent2cd769179345799d383f92dd615991755ec24be1 (diff)
r600g: plug in optimizing backend
Optimization is enabled with "R600_DEBUG=sb". Signed-off-by: Vadim Girlin <[email protected]>
Diffstat (limited to 'src/gallium/drivers/r600/Makefile.am')
-rw-r--r--src/gallium/drivers/r600/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/gallium/drivers/r600/Makefile.am b/src/gallium/drivers/r600/Makefile.am
index 43c8704618d..35c75ad76c7 100644
--- a/src/gallium/drivers/r600/Makefile.am
+++ b/src/gallium/drivers/r600/Makefile.am
@@ -10,8 +10,16 @@ AM_CFLAGS = \
$(RADEON_CFLAGS) \
$(VISIBILITY_CFLAGS)
+AM_CXXFLAGS = \
+ -I$(top_srcdir)/src/gallium/drivers \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/src/gallium/include \
+ -I$(top_srcdir)/src/gallium/auxiliary \
+ $(DEFINES)
+
libr600_la_SOURCES = \
- $(C_SOURCES)
+ $(C_SOURCES) \
+ $(CXX_SOURCES)
libr600_la_LIBADD = ../radeon/libradeon.la