aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/freedreno/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2013-11-01 18:58:27 +0000
committerEmil Velikov <[email protected]>2013-11-16 16:29:28 +0000
commit7dac1b470a9c1c977f79ecc301407681e200bd1a (patch)
tree39c8b75ac8223811cf006c87658c1b131e75cb0f /src/gallium/drivers/freedreno/Makefile.am
parentad501a535ad731447587b259afe2ea9c0a0a02f5 (diff)
gallium/drivers: compact compiler flags into Automake.inc
* minimise flags duplication * distingush between VISIBILITY C and CXX flags * set only required flags - C and/or CXX v2: add LLVM_CFLAGS back to AM_CFLAGS (add missing backslash) Signed-off-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/gallium/drivers/freedreno/Makefile.am')
-rw-r--r--src/gallium/drivers/freedreno/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/src/gallium/drivers/freedreno/Makefile.am b/src/gallium/drivers/freedreno/Makefile.am
index a7b307a021b..7947dd1a56e 100644
--- a/src/gallium/drivers/freedreno/Makefile.am
+++ b/src/gallium/drivers/freedreno/Makefile.am
@@ -3,16 +3,14 @@ AUTOMAKE_OPTIONS = subdir-objects
include Makefile.sources
include $(top_srcdir)/src/gallium/Automake.inc
-noinst_LTLIBRARIES = libfreedreno.la
-
AM_CFLAGS = \
-Wno-packed-bitfield-compat \
- -I$(top_srcdir)/src/gallium/drivers \
-I$(top_srcdir)/src/gallium/drivers/freedreno/a3xx \
-I$(top_srcdir)/src/gallium/drivers/freedreno/a2xx \
- $(GALLIUM_CFLAGS) \
- $(FREEDRENO_CFLAGS) \
- $(VISIBILITY_CFLAGS)
+ $(GALLIUM_DRIVER_CFLAGS) \
+ $(FREEDRENO_CFLAGS)
+
+noinst_LTLIBRARIES = libfreedreno.la
libfreedreno_la_SOURCES = \
$(C_SOURCES) \