aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2014-05-10 14:35:08 +0100
committerEmil Velikov <[email protected]>2014-05-15 17:32:30 +0100
commitd812c745829be2155fdd0d10e4a12606c2a10826 (patch)
tree21177e54bb2eb6676774ca478b153b80276f6014 /src/gallium/drivers/Makefile.am
parent6fcc0b0ba5b5a554682b782ee5f7930d7aabbe8e (diff)
gallium/radeon: link in libradeon.la at target level
It makes more sense to link the core and common parts of the driver as the target is build. Additionally this will help us drop duplicating symbols for targets that static link mulitple pipe-drivers. Only egl-static needs that currently with more to come. To simplify things a bit add HAVE_GALLIUM_RADEON_COMMON variable. Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Tom Stellard <[email protected]>
Diffstat (limited to 'src/gallium/drivers/Makefile.am')
-rw-r--r--src/gallium/drivers/Makefile.am24
1 files changed, 8 insertions, 16 deletions
diff --git a/src/gallium/drivers/Makefile.am b/src/gallium/drivers/Makefile.am
index f8baa3cf92c..3d53cade7b8 100644
--- a/src/gallium/drivers/Makefile.am
+++ b/src/gallium/drivers/Makefile.am
@@ -5,22 +5,6 @@ SUBDIRS = . galahad identity noop trace rbug
################################################################################
-if HAVE_GALLIUM_R600
-
-SUBDIRS += radeon
-
-else
-
-if HAVE_GALLIUM_RADEONSI
-
-SUBDIRS += radeon
-
-endif
-
-endif
-
-################################################################################
-
if HAVE_GALLIUM_FREEDRENO
SUBDIRS += freedreno
@@ -61,6 +45,14 @@ endif
################################################################################
+if HAVE_GALLIUM_RADEON_COMMON
+
+SUBDIRS += radeon
+
+endif
+
+################################################################################
+
if HAVE_GALLIUM_R300
SUBDIRS += r300