aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/auxiliary/meson.build
diff options
context:
space:
mode:
authorBas Nieuwenhuizen <[email protected]>2019-06-05 14:34:23 +0200
committerBas Nieuwenhuizen <[email protected]>2019-06-13 08:25:48 +0000
commitcb728f28acbf8982d37aa3863cae58db95a439ca (patch)
tree1f85a2195b437d2cfb69f9c9d55da553b6e8d0a6 /src/gallium/auxiliary/meson.build
parentb4c7ce360bc07c507de120d218c7479161c22bc2 (diff)
vl: Always enable drm winsys.
The dri2 winsys also uses libdrm (and you can only enable dri3 if you enable dri2), and the drm winsys only requires libdrm. So if any winsys is enabled you can also enable the drm winsys, and since we always want at least one winsys we can always enable it. I removed the check for the drm platform for VA and OMX since they do not care anymore. Since we still check for one of r600g, nouveau or radeonsi, we are guarantueed to still only enable it by default in a configuration that requires libdrm anyway. So for people using va=auto, we don't suddenly start requiring libdrm were we did not before. This supersedes "vl: Enable DRM by default.", which I pushed, but rolled back because it used dep_libdrm before its definition. Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/gallium/auxiliary/meson.build')
-rw-r--r--src/gallium/auxiliary/meson.build6
1 files changed, 2 insertions, 4 deletions
diff --git a/src/gallium/auxiliary/meson.build b/src/gallium/auxiliary/meson.build
index e76b2ac912e..1b8d32d128b 100644
--- a/src/gallium/auxiliary/meson.build
+++ b/src/gallium/auxiliary/meson.build
@@ -479,7 +479,8 @@ files_libgalliumvl = files(
)
vlwinsys_deps = []
-files_libgalliumvlwinsys = files('vl/vl_winsys.h')
+files_libgalliumvlwinsys = files('vl/vl_winsys.h',
+ 'vl/vl_winsys_drm.c')
if with_dri2 and with_platform_x11
files_libgalliumvlwinsys += files('vl/vl_winsys_dri.c')
if with_dri3
@@ -490,9 +491,6 @@ if with_dri2 and with_platform_x11
files_libgalliumvlwinsys += files('vl/vl_winsys_dri3.c')
endif
endif
-if with_platform_drm
- files_libgalliumvlwinsys += files('vl/vl_winsys_drm.c')
-endif
u_indices_gen_c = custom_target(
'u_indices_gen.c',