aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/auxiliary/meson.build
diff options
context:
space:
mode:
authorDave Airlie <[email protected]>2019-09-05 15:32:21 +1000
committerDave Airlie <[email protected]>2019-11-28 14:48:11 +1000
commit3b9950098b14ef6fa30035be9ffc847722a363cb (patch)
tree6086616fa21b43abeb762ef6f8ca2394596fa0e4 /src/gallium/auxiliary/meson.build
parentc879efec0973a4b1c9e6baa94351feb9aaeb3f36 (diff)
gallivm: nir->tgsi info convertor (v2)
This is a port of the old radeonsi code to be used for llvmpipe NIR support. Once we remove TGSI support from llvmpipe (I can dream? :-), then we should be able to refine most of this down and remove it. v2: port to later radeonsi code for vertex inputs and sampler/io parsing. Acked-by: Roland Scheidegger <[email protected]>
Diffstat (limited to 'src/gallium/auxiliary/meson.build')
-rw-r--r--src/gallium/auxiliary/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/gallium/auxiliary/meson.build b/src/gallium/auxiliary/meson.build
index 27cd8207e14..aaf5138a169 100644
--- a/src/gallium/auxiliary/meson.build
+++ b/src/gallium/auxiliary/meson.build
@@ -417,6 +417,8 @@ if with_llvm
'draw/draw_llvm_sample.c',
'draw/draw_pt_fetch_shade_pipeline_llvm.c',
'draw/draw_vs_llvm.c',
+ 'nir/nir_to_tgsi_info.c',
+ 'nir/nir_to_tgsi_info.h',
)
endif