aboutsummaryrefslogtreecommitdiffstats
path: root/src/gallium/auxiliary/meson.build
diff options
context:
space:
mode:
authorDave Airlie <[email protected]>2020-03-27 11:33:43 +1000
committerDave Airlie <[email protected]>2020-04-15 14:26:29 +1000
commit381e9fe64a80d98144a4ad75044edd9b878c7de7 (patch)
tree8037142f5a15d5419630c9d6fd25f1bf39d13283 /src/gallium/auxiliary/meson.build
parent30ef6f5137a5a6e9c0b08640a44e30e1aba14270 (diff)
draw: fix user culling pipeline order. (v2)
GL spec requires user culling, then clipping then face culling. llvmpipe was doing clipping then user culling then face culling. Fix the ordering by adding a new user_cull stage that does the user culling Fixes piglit clip_cull-4.shader_test v2: simplify this a lot (Roland) Reviewed-by: Roland Scheidegger <[email protected]> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4560>
Diffstat (limited to 'src/gallium/auxiliary/meson.build')
-rw-r--r--src/gallium/auxiliary/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/gallium/auxiliary/meson.build b/src/gallium/auxiliary/meson.build
index 7db7614ebb5..8b02084c0d0 100644
--- a/src/gallium/auxiliary/meson.build
+++ b/src/gallium/auxiliary/meson.build
@@ -46,6 +46,7 @@ files_libgallium = files(
'draw/draw_pipe_stipple.c',
'draw/draw_pipe_twoside.c',
'draw/draw_pipe_unfilled.c',
+ 'draw/draw_pipe_user_cull.c',
'draw/draw_pipe_util.c',
'draw/draw_pipe_validate.c',
'draw/draw_pipe_vbuf.c',