aboutsummaryrefslogtreecommitdiffstats
path: root/src/freedreno/ir3/meson.build
diff options
context:
space:
mode:
authorKristian H. Kristensen <[email protected]>2019-10-10 17:17:10 -0700
committerKristian H. Kristensen <[email protected]>2019-10-17 13:43:53 -0700
commit8e16fb152813d13121d13710f72ecce009c1885e (patch)
treee85c93fd326b3b0f724011607d85b8f4a77d0f77 /src/freedreno/ir3/meson.build
parent8f39985b01b34cbb6a84b4614f5cb732748954d1 (diff)
freedreno/ir3: Implement lowering passes for VS and GS
This introduces two new lowering passes. One to lower VS to explicit outputs using STLW and one to lower GS to load input using LDLW and implement the GS specific functionality. Signed-off-by: Kristian H. Kristensen <[email protected]>
Diffstat (limited to 'src/freedreno/ir3/meson.build')
-rw-r--r--src/freedreno/ir3/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/freedreno/ir3/meson.build b/src/freedreno/ir3/meson.build
index be03ffb88c3..6e1434057e7 100644
--- a/src/freedreno/ir3/meson.build
+++ b/src/freedreno/ir3/meson.build
@@ -66,6 +66,7 @@ libfreedreno_ir3_files = files(
'ir3_nir_lower_load_barycentric_at_sample.c',
'ir3_nir_lower_load_barycentric_at_offset.c',
'ir3_nir_lower_io_offsets.c',
+ 'ir3_nir_lower_tess.c',
'ir3_nir_lower_tg4_to_tex.c',
'ir3_nir_move_varying_inputs.c',
'ir3_print.c',