aboutsummaryrefslogtreecommitdiffstats
path: root/src/freedreno/drm/meson.build
diff options
context:
space:
mode:
authorRob Clark <[email protected]>2018-11-11 10:10:46 -0500
committerRob Clark <[email protected]>2018-11-27 15:44:02 -0500
commitb4476138d5ad3f8d30c14ee61f2f375edfdbab2a (patch)
tree023f9d60e21ad74aa341bf49cfd07a4cb5ed5a03 /src/freedreno/drm/meson.build
parent6cb74eb4f1499d6e319a1c96d16174038e22540d (diff)
freedreno: move drm to common location
So that we can re-use at least parts of it for vulkan driver, and so that we can move ir3 to a common location (which uses fd_bo to allocate storage for shaders) Signed-off-by: Rob Clark <[email protected]>
Diffstat (limited to 'src/freedreno/drm/meson.build')
-rw-r--r--src/freedreno/drm/meson.build54
1 files changed, 54 insertions, 0 deletions
diff --git a/src/freedreno/drm/meson.build b/src/freedreno/drm/meson.build
new file mode 100644
index 00000000000..5679d147894
--- /dev/null
+++ b/src/freedreno/drm/meson.build
@@ -0,0 +1,54 @@
+# Copyright © 2018 Rob Clark
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+libfreedreno_drm_files = files(
+ 'freedreno_bo.c',
+ 'freedreno_bo_cache.c',
+ 'freedreno_device.c',
+ 'freedreno_drmif.h',
+ 'freedreno_pipe.c',
+ 'freedreno_priv.h',
+ 'freedreno_ringbuffer.c',
+ 'freedreno_ringbuffer.h',
+ 'msm_bo.c',
+ 'msm_device.c',
+ 'msm_drm.h',
+ 'msm_pipe.c',
+ 'msm_priv.h',
+ 'msm_ringbuffer.c',
+ 'msm_ringbuffer_sp.c',
+)
+
+libfreedreno_drm = static_library(
+ 'freedreno_drm',
+ libfreedreno_drm_files,
+ include_directories : [
+ inc_freedreno,
+ inc_common,
+ ],
+ c_args : [c_vis_args, no_override_init_args],
+ cpp_args : [cpp_vis_args],
+ dependencies : [
+ dep_libdrm,
+ dep_valgrind,
+ ],
+ build_by_default : false,
+)
+