aboutsummaryrefslogtreecommitdiffstats
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2018-05-17 13:44:30 -0700
committerDylan Baker <[email protected]>2019-05-03 10:58:05 -0700
commitff9bf223c24143260a975f45963eb90f40565c57 (patch)
treec8ec393ae985491da3d8812b36a8be586dbfaaad /src/egl/meson.build
parentf5eafc2dc6a68c9c2c2660dff528de1ecdedf4dc (diff)
meson: make nm binary optional
This makes nm not required, but used if found. In general I imagine that this means that on windows nm wont be found, and on other platforms it will. v2: - fix gbm and egl symbols check tests to only be run if nm is found - reword commit message to reflect the code change Reviewed-by: Eric Anholt <[email protected]>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index 38ffb512f1c..3a0fd01d244 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -192,7 +192,7 @@ pkg.generate(
extra_cflags : gl_pkgconfig_c_flags,
)
-if with_tests
+if with_tests and prog_nm.found()
if with_glvnd
# TODO: add glvnd symbol check
else