aboutsummaryrefslogtreecommitdiffstats
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2018-12-09 19:51:15 +0000
committerEmil Velikov <[email protected]>2019-01-24 18:13:25 +0000
commitcd0f11bac55b14728cf70e39cd269a70aeb2b5d4 (patch)
treede576991eaac33b7fa1e2ce3640a35ac547b820a /src/egl/meson.build
parenta08a793180716770e8a4509447b8621cc57304bc (diff)
mapi: move genCommon.py to src/mapi/new
The helper will also be used by the new Khronos gl.xml aware generator. v2: Move existing one, instead of duplicating it. v3: Correct genCommon.py references in meson [Erik] v4: Drop the file from the EGL EXTRA_DIST [Erik] Suggested-by: Kyle Brenneman <[email protected]> Signed-off-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index 461892f5ae8..a23cc36fc2b 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -1,4 +1,4 @@
-# Copyright © 2017 Intel Corporation
+# Copyright © 2017 Intel Corporation
# Permission is hereby granted, free of charge, to any person obtaining a copy
# of this software and associated documentation files (the "Software"), to deal
@@ -69,7 +69,7 @@ g_egldispatchstubs_c = custom_target(
command : [
prog_python, '@INPUT0@', 'source', '@INPUT1@', '@INPUT2@',
],
- depend_files : files('generate/eglFunctionList.py', 'generate/genCommon.py'),
+ depend_files : [ files('generate/eglFunctionList.py'), genCommon_py, ],
capture : true,
)
@@ -83,7 +83,7 @@ g_egldispatchstubs_h = custom_target(
command : [
prog_python, '@INPUT0@', 'header', '@INPUT1@', '@INPUT2@',
],
- depend_files : files('generate/eglFunctionList.py', 'generate/genCommon.py'),
+ depend_files : [ files('generate/eglFunctionList.py'), genCommon_py, ],
capture : true,
)