aboutsummaryrefslogtreecommitdiffstats
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2018-11-07 13:07:09 +0000
committerEric Engestrom <[email protected]>2019-01-13 13:59:08 +0000
commitbdf6a5c1d2e01aed88a338c403f28a4b9898068e (patch)
treef7696ecacb43e577328a1bbce65cdfc703b5f83b /src/egl/meson.build
parentb938d5fbefe09c67318e88eb869cab016fc6749b (diff)
egl: fix python lib deprecation warning
DeprecationWarning: the imp module is deprecated in favour of importlib Instead of complicated logic, just import the file directly. Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Jordan Justen <[email protected]>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build12
1 files changed, 6 insertions, 6 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index 89bac2cd633..461892f5ae8 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -62,28 +62,28 @@ files_egl = files(
g_egldispatchstubs_c = custom_target(
'g_egldispatchstubs.c',
input : [
- 'generate/gen_egl_dispatch.py', 'generate/eglFunctionList.py',
+ 'generate/gen_egl_dispatch.py',
'generate/egl.xml', 'generate/egl_other.xml'
],
output : 'g_egldispatchstubs.c',
command : [
- prog_python, '@INPUT0@', 'source', '@INPUT1@', '@INPUT2@', '@INPUT3@'
+ prog_python, '@INPUT0@', 'source', '@INPUT1@', '@INPUT2@',
],
- depend_files : files('generate/genCommon.py'),
+ depend_files : files('generate/eglFunctionList.py', 'generate/genCommon.py'),
capture : true,
)
g_egldispatchstubs_h = custom_target(
'g_egldispatchstubs.h',
input : [
- 'generate/gen_egl_dispatch.py', 'generate/eglFunctionList.py',
+ 'generate/gen_egl_dispatch.py',
'generate/egl.xml', 'generate/egl_other.xml'
],
output : 'g_egldispatchstubs.h',
command : [
- prog_python, '@INPUT0@', 'header', '@INPUT1@', '@INPUT2@', '@INPUT3@'
+ prog_python, '@INPUT0@', 'header', '@INPUT1@', '@INPUT2@',
],
- depend_files : files('generate/genCommon.py'),
+ depend_files : files('generate/eglFunctionList.py', 'generate/genCommon.py'),
capture : true,
)