aboutsummaryrefslogtreecommitdiffstats
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2015-07-24 16:19:55 +0200
committerEmil Velikov <[email protected]>2018-11-01 00:05:43 +0000
commit7552fcb7b9b98392e6a815ff587f9f2d200d6a37 (patch)
treee9ce7e95320b3fae6f2527329ddab985da9e6db6 /src/egl/meson.build
parente55c1bcb08ff30c923f7f1dc6d4283927cdc574c (diff)
egl: add base EGL_EXT_device_base implementation
Introduce the API for device query and enumeration. Those at the moment produce nothing useful since zero devices are actually available. That contradicts with the spec, so the extension isn't advertised just yet. With later commits we'll add support for software (always) and hardware devices. Each one exposing the respective extension string. v2: - fold API boilerplate into this patch - move _eglAddDevice, _eglDeviceSupports, _eglRefreshDeviceList to this patch (Eric, Mathias) - make _eglFiniDevice the one called last v3: - comment on the dummy _egl_device_extension enum entry (Eric) - annotate dev as MAYBE_UNUSED (Mathias) Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Mathias Fröhlich <[email protected]>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index e11e589b945..80dbcae0fd3 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -38,6 +38,8 @@ files_egl = files(
'main/eglcurrent.c',
'main/eglcurrent.h',
'main/egldefines.h',
+ 'main/egldevice.c',
+ 'main/egldevice.h',
'main/egldisplay.c',
'main/egldisplay.h',
'main/egldriver.c',