aboutsummaryrefslogtreecommitdiffstats
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorMathieu Bridon <[email protected]>2018-08-09 10:27:26 +0200
committerDylan Baker <[email protected]>2018-08-10 15:15:09 -0700
commit2ee1c86d71bee5ddca2c8795b4d343e31d28df99 (patch)
tree434ff307fe52734f62ae83427accc863cb455778 /src/egl/meson.build
parentbd27203f4d808763ac24ac94eb677cacf3e7cb99 (diff)
meson: Build with Python 3
Now that all the build scripts are compatible with both Python 2 and 3, we can flip the switch and tell Meson to use the latter. Since Meson already depends on Python 3 anyway, this means we don't need two different Python stacks to build Mesa. Signed-off-by: Mathieu Bridon <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index 89a84fd8908..1d63f0f087c 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -65,7 +65,7 @@ g_egldispatchstubs_c = custom_target(
],
output : 'g_egldispatchstubs.c',
command : [
- prog_python2, '@INPUT0@', 'source', '@INPUT1@', '@INPUT2@', '@INPUT3@'
+ prog_python, '@INPUT0@', 'source', '@INPUT1@', '@INPUT2@', '@INPUT3@'
],
depend_files : files('generate/genCommon.py'),
capture : true,
@@ -79,7 +79,7 @@ g_egldispatchstubs_h = custom_target(
],
output : 'g_egldispatchstubs.h',
command : [
- prog_python2, '@INPUT0@', 'header', '@INPUT1@', '@INPUT2@', '@INPUT3@'
+ prog_python, '@INPUT0@', 'header', '@INPUT1@', '@INPUT2@', '@INPUT3@'
],
depend_files : files('generate/genCommon.py'),
capture : true,