aboutsummaryrefslogtreecommitdiffstats
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2018-05-29 15:41:28 +0100
committerMatt Turner <[email protected]>2018-06-06 12:11:57 -0700
commit1db4ec05462914096b1f243e9b2af7e71cf38622 (patch)
tree5adb834423c95a80eeb12e44e4d7ad955531ed45 /src/egl/meson.build
parent67f7a16b598513d25319e482359a4c4c6fc1271d (diff)
egl: rewire the build systems to use libwayland-egl
Cc: Emil Velikov <[email protected]> Cc: Daniel Stone <[email protected]> Reviewed-by: Matt Turner <[email protected]> Signed-off-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build10
1 files changed, 2 insertions, 8 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index 9050d763a6c..dc67b7b1536 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -116,7 +116,7 @@ if with_platform_surfaceless
files_egl += files('drivers/dri2/platform_surfaceless.c')
endif
if with_platform_wayland
- deps_for_egl += [dep_wayland_client, dep_wayland_server]
+ deps_for_egl += [dep_wayland_client, dep_wayland_server, dep_wayland_egl]
link_for_egl += libwayland_drm
files_egl += files('drivers/dri2/platform_wayland.c')
files_egl += [
@@ -124,9 +124,7 @@ if with_platform_wayland
linux_dmabuf_unstable_v1_client_protocol_h,
wayland_drm_client_protocol_h,
]
- incs_for_egl += include_directories(
- 'wayland/wayland-egl', 'wayland/wayland-drm',
- )
+ incs_for_egl += include_directories('wayland/wayland-drm')
endif
if with_platform_android
deps_for_egl += dep_android
@@ -198,10 +196,6 @@ pkg.generate(
extra_cflags : gl_pkgconfig_c_flags,
)
-if with_platform_wayland
- subdir('wayland/wayland-egl')
-endif
-
if with_tests
if with_glvnd
# TODO: add glvnd symbol check