aboutsummaryrefslogtreecommitdiffstats
path: root/src/egl/drivers/dri2/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2015-07-13 22:20:38 +0100
committerEmil Velikov <[email protected]>2015-07-22 16:35:26 +0100
commitdc1ece3748f3a97d685c9c72ad26684fd35f1944 (patch)
treeacaf73f41450c42aab788bbc9a601ea9893dc9b4 /src/egl/drivers/dri2/Makefile.am
parent78674631a2d0ff1eb538470e2a1d516201361f03 (diff)
egl: remove flatten HAVE_SHARED_GLAPI
It is simply not possible to use the dri backend without shared glapi, as the alternative provider (libGL) is not always present. We have fixed the build for a while now, so we can rip this out. Signed-off-by: Emil Velikov <[email protected]> Reviewed-by: Matt Turner <[email protected]>
Diffstat (limited to 'src/egl/drivers/dri2/Makefile.am')
-rw-r--r--src/egl/drivers/dri2/Makefile.am4
1 files changed, 0 insertions, 4 deletions
diff --git a/src/egl/drivers/dri2/Makefile.am b/src/egl/drivers/dri2/Makefile.am
index f4649de18df..b59360de123 100644
--- a/src/egl/drivers/dri2/Makefile.am
+++ b/src/egl/drivers/dri2/Makefile.am
@@ -44,10 +44,6 @@ libegl_dri2_la_LIBADD = \
$(top_builddir)/src/loader/libloader.la \
$(EGL_LIB_DEPS)
-if HAVE_SHARED_GLAPI
-AM_CFLAGS += -DHAVE_SHARED_GLAPI
-endif
-
if HAVE_EGL_PLATFORM_X11
libegl_dri2_la_SOURCES += platform_x11.c
AM_CFLAGS += -DHAVE_X11_PLATFORM