aboutsummaryrefslogtreecommitdiffstats
path: root/src/egl/Makefile.am
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2017-10-30 15:43:10 +0000
committerEric Engestrom <[email protected]>2017-10-31 17:59:49 +0000
commit64f17440b65b3065ba3d14155cd3da831200e49c (patch)
tree8dcdf8ef336246e0cf68a990e903005d917a2bc8 /src/egl/Makefile.am
parent1946de2b71b08cd60e6a108cf642d82086be8236 (diff)
automake+meson: don't run egl symbol check on libglvnd lib
We might want to add a symbol check for the glvnd variant though. Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'src/egl/Makefile.am')
-rw-r--r--src/egl/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/src/egl/Makefile.am b/src/egl/Makefile.am
index eeb745f973a..eaec4ff946f 100644
--- a/src/egl/Makefile.am
+++ b/src/egl/Makefile.am
@@ -201,8 +201,13 @@ egl_HEADERS = \
$(top_srcdir)/include/EGL/eglmesaext.h \
$(top_srcdir)/include/EGL/eglplatform.h
-TESTS = egl-symbols-check \
- egl-entrypoint-check
+TESTS = egl-entrypoint-check
+
+if USE_LIBGLVND
+#TODO: glvnd symbol check
+else
+TESTS += egl-symbols-check
+endif
EXTRA_DIST = \
$(TESTS) \