aboutsummaryrefslogtreecommitdiffstats
path: root/src/compiler/nir/meson.build
diff options
context:
space:
mode:
authorKarol Herbst <[email protected]>2018-07-12 15:02:27 +0200
committerKarol Herbst <[email protected]>2019-03-05 22:28:29 +0100
commit272e927d0e9fed6e791d706ff5d895b6c2036fc0 (patch)
tree2bbe3b7fbef9275137bd4669cb86b72181094379 /src/compiler/nir/meson.build
parentd0b47ec4df0eafe4f4afddc2a0594b392c27f426 (diff)
nir/spirv: initial handling of OpenCL.std extension opcodes
Not complete, mostly just adding things as I encounter them in CTS. But not getting far enough yet to hit most of the OpenCL.std instructions. Anyway, this is better than nothing and covers the most common builtins. v2: add hadd proof from Jason move some of the lowering into opt_algebraic and create new nir opcodes simplify nextafter lowering fix normalize lowering for inf rework upsample to use nir_pack_bits add missing files to build systems v3: split lines of iadd/sub_sat expressions Signed-off-by: Karol Herbst <[email protected]> Reviewed-by: Jason Ekstrand <[email protected]>
Diffstat (limited to 'src/compiler/nir/meson.build')
-rw-r--r--src/compiler/nir/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/compiler/nir/meson.build b/src/compiler/nir/meson.build
index d7f88f391f4..af781f9a2d5 100644
--- a/src/compiler/nir/meson.build
+++ b/src/compiler/nir/meson.build
@@ -203,6 +203,7 @@ files_libnir = files(
'../spirv/GLSL.std.450.h',
'../spirv/gl_spirv.c',
'../spirv/nir_spirv.h',
+ '../spirv/OpenCL.std.h',
'../spirv/spirv.h',
'../spirv/spirv_info.h',
'../spirv/spirv_to_nir.c',
@@ -210,6 +211,7 @@ files_libnir = files(
'../spirv/vtn_amd.c',
'../spirv/vtn_cfg.c',
'../spirv/vtn_glsl450.c',
+ '../spirv/vtn_opencl.c',
'../spirv/vtn_private.h',
'../spirv/vtn_subgroup.c',
'../spirv/vtn_variables.c',