aboutsummaryrefslogtreecommitdiffstats
path: root/src/compiler/meson.build
diff options
context:
space:
mode:
authorIan Romanick <[email protected]>2017-08-14 10:40:09 -0700
committerIan Romanick <[email protected]>2018-03-29 14:16:01 -0700
commit042ee4bea26272bd7c358cc9541e576a8352890c (patch)
treed03707e886103019722ee20ba86cdf57c67b7097 /src/compiler/meson.build
parent2c9621ee5c5fa40be071858f99fb256fc37369b4 (diff)
spirv: Move SPIR-V building to Makefile.spirv.am and spirv/meson.build
Future changes will add generated files used only from src/compiler/glsl. These can't be built from Makefile.nir.am, and we can't move all the rules from Makefile.nir.am to Makefile.spirv.am (and it would be silly anyway). v2: Do it for meson too. Signed-off-by: Ian Romanick <[email protected]> Reviewed-by: Eric Engestrom <[email protected]> (the meson bits) Reviewed-by: Alejandro PiƱeiro <[email protected]> (the automake bits)
Diffstat (limited to 'src/compiler/meson.build')
-rw-r--r--src/compiler/meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/compiler/meson.build b/src/compiler/meson.build
index e955e66f811..da2464d7b8c 100644
--- a/src/compiler/meson.build
+++ b/src/compiler/meson.build
@@ -21,6 +21,7 @@
inc_compiler = include_directories('.')
inc_nir = include_directories('nir')
inc_glsl = include_directories('glsl')
+inc_spirv = include_directories('spirv')
files_libcompiler = files(
'blob.c',
@@ -53,8 +54,12 @@ libcompiler = static_library(
build_by_default : false,
)
+subdir('spirv')
+
subdir('nir')
+# This is here because putting it in spirv/meson.build would create a circular
+# dependency with nir/meson.build.
spirv2nir = executable(
'spirv2nir',
[files('spirv/spirv2nir.c'), dummy_cpp],