aboutsummaryrefslogtreecommitdiffstats
path: root/src/compiler/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2017-08-28 13:52:12 -0700
committerMatt Turner <[email protected]>2017-08-29 15:20:57 -0700
commitf99bde0dad01bf7c1c89ff3d2553930530848eec (patch)
tree35311835a43ac157663e5f8a58d9a4c1e8f16f7e /src/compiler/Makefile.am
parentc5d2e2d43f697d4d9d35542f3839fcacaf848885 (diff)
compiler: Add $(WNO_OVERRIDE_INIT) to AM_CFLAGS
nir_intrinsics.h does this a lot, causing lots of warnings from clang. Reviewed-by: Emil Velikov <[email protected]> Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'src/compiler/Makefile.am')
-rw-r--r--src/compiler/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/compiler/Makefile.am b/src/compiler/Makefile.am
index 001ff81aeb0..45b9cc58543 100644
--- a/src/compiler/Makefile.am
+++ b/src/compiler/Makefile.am
@@ -42,6 +42,7 @@ AM_CPPFLAGS = \
AM_CFLAGS = \
$(VISIBILITY_CFLAGS) \
+ $(WNO_OVERRIDE_INIT) \
$(MSVC2013_COMPAT_CFLAGS)
AM_CXXFLAGS = \