aboutsummaryrefslogtreecommitdiffstats
path: root/src/amd/vulkan/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <[email protected]>2018-06-19 15:58:30 -0700
committerKeith Packard <[email protected]>2018-06-20 10:42:05 -0700
commit3f960c1338713d317ce6463be68cee162c968d8d (patch)
tree87c94a88d89cef1fb043d05aaaea2d853e824a37 /src/amd/vulkan/Makefile.am
parentf49d112a01f9bec79b0ddb028163dc189f663634 (diff)
vulkan: EXT_acquire_xlib_display requires libXrandr headers to build
When VK_USE_PLATFORM_XLIB_XRANDR_EXT is defined, vulkan.h includes X11/extensions/Xrandr.h for the RROutput typedef which is used in the vkGetRandROutputDisplayEXT interface. Make sure we have the required header by checking during the build, and also set CFLAGS to point at the right directory. We don't need to link against the library as we don't use any functions from there, so don't add the _LIBS value in the autotools build. Signed-off-by: Keith Packard <[email protected]> Fixes: dbac8e25f851ed44c51f "radv: Add EXT_acquire_xlib_display to radv driver [v2]" Reviewed-by: Eric Engestrom <[email protected]>
Diffstat (limited to 'src/amd/vulkan/Makefile.am')
-rw-r--r--src/amd/vulkan/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/amd/vulkan/Makefile.am b/src/amd/vulkan/Makefile.am
index 8279fe4a81f..f9d3622f744 100644
--- a/src/amd/vulkan/Makefile.am
+++ b/src/amd/vulkan/Makefile.am
@@ -90,7 +90,8 @@ endif
if HAVE_XLIB_LEASE
AM_CPPFLAGS += \
-DVK_USE_PLATFORM_XLIB_XRANDR_EXT \
- $(XCB_RANDR_CFLAGS)
+ $(XCB_RANDR_CFLAGS) \
+ $(XLIB_RANDR_CFLAGS)
VULKAN_LIB_DEPS += $(XCB_RANDR_LIBS)
endif