aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorEric Anholt <[email protected]>2017-11-08 11:52:09 -0800
committerEric Anholt <[email protected]>2017-11-09 09:40:03 -0800
commitd975e6940e2e511825a2feb31b5b1da7e6e23248 (patch)
tree0ab64a7d40edfac5e4db6a5198ab44e11de6bb88 /meson.build
parent015cc6bb7cd1199ce43018bb47c89c0a26adc96a (diff)
meson: Leave dep_llvm empty if !with_llvm
The gallium auxiliary build would link against llvm, for the gallivm code that it didn't build. This broke the build on my armhf cross, where libLLVM-3.9.so is not multiarch and thus points to x86-64 libs. Reviewed-by: Dylan Baker <[email protected]> Tested-by: Timothy Arceri <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 4 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 314d15ac461..d8a8bb00660 100644
--- a/meson.build
+++ b/meson.build
@@ -661,10 +661,11 @@ llvm_modules = ['bitwriter', 'engine', 'mcdisassembler', 'mcjit']
if with_amd_vk
llvm_modules += ['amdgpu', 'bitreader', 'ipo']
endif
-dep_llvm = dependency(
- 'llvm', version : '>= 3.9.0', required : with_amd_vk, modules : llvm_modules,
-)
+dep_llvm = []
if with_llvm
+ dep_llvm = dependency(
+ 'llvm', version : '>= 3.9.0', required : with_amd_vk, modules : llvm_modules,
+ )
if dep_llvm.found()
_llvm_version = dep_llvm.version().split('.')
# Development versions of LLVM have an 'svn' suffix, we don't want that for