aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorJon Turney <[email protected]>2017-12-03 21:58:12 +0000
committerJon Turney <[email protected]>2018-02-05 19:40:43 +0000
commit80bc41b2ec7cf06662e16cbbb610c40a552d66a3 (patch)
tree44009fe3d9a928317700cf95ded494b2d61683bf /meson.build
parentea8730024ff29f76c27e90746a786298785927e2 (diff)
meson: osx ld doesn't support --build-id
Signed-off-by: Jon Turney <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 030ab0c6260..b61c285bf00 100644
--- a/meson.build
+++ b/meson.build
@@ -909,6 +909,10 @@ if cc.links('int main() { return 0; }',
name : 'dynamic-list')
with_ld_dynamic_list = true
endif
+ld_args_build_id = []
+if build_machine.system() != 'darwin'
+ ld_args_build_id += '-Wl,--build-id=sha1'
+endif
# check for dl support
if cc.has_function('dlopen')