aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <[email protected]>2017-09-30 09:03:51 -0700
committerDylan Baker <[email protected]>2017-10-16 16:32:43 -0700
commit66f97f6640f5316b36177fd1053f0027eb6ec6cc (patch)
treea8ff77cec74ce99f388ababab206b8d39f8c5a6a /meson.build
parentf3d03a2cf7e84d67f6be8c61fe93312c4ed8393b (diff)
meson: build radeonsi
This builds the radeonsi (and radeon) window system bits and gallium driver bits. Signed-off-by: Dylan Baker <[email protected]> Reviewed-by: Eric Anholt <eric at anholt.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build18
1 files changed, 13 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 4cde8c76908..ebaf2d957fd 100644
--- a/meson.build
+++ b/meson.build
@@ -543,7 +543,15 @@ dep_expat = dependency('expat')
# this only exists on linux so either this is linux and it will be found, or
# its not linux and and wont
dep_m = cc.find_library('m', required : false)
-dep_libdrm_amdgpu = dependency('libdrm_amdgpu', version : '>= 2.4.82', required : with_amd_vk)
+
+dep_libdrm_amdgpu = []
+dep_libdrm_radeon = []
+if with_amd_vk or with_gallium_radeonsi
+ dep_libdrm_amdgpu = dependency('libdrm_amdgpu', version : '>= 2.4.84')
+endif
+if with_gallium_radeonsi # older radeon too
+ dep_libdrm_radeon = dependency('libdrm_radeon', version : '>= 2.4.71')
+endif
llvm_modules = ['bitwriter', 'engine', 'mcdisassembler', 'mcjit']
if with_amd_vk
@@ -566,12 +574,12 @@ if with_llvm
'-DMESA_LLVM_VERSION_PATCH=@0@'.format(_llvm_patch),
]
else
- if with_amd_vk
- error('The following drivers requires LLVM: Radv. One of these is enabled, but LLVM was not found.')
+ if with_amd_vk or with_gallium_radeonsi
+ error('The following drivers requires LLVM: Radv, RadeonSI. One of these is enabled, but LLVM was not found.')
endif
endif
-elif with_amd_vk
- error('The following drivers requires LLVM: Radv. One of these is enabled, but LLVM is disabled.')
+elif with_amd_vk or with_gallium_radeonsi
+ error('The following drivers requires LLVM: Radv, RadeonSI. One of these is enabled, but LLVM is disabled.')
endif
dep_glvnd = []