aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorChia-I Wu <[email protected]>2019-03-08 11:27:50 -0800
committerChia-I Wu <[email protected]>2019-03-11 10:02:13 -0700
commit4f863dc0f72719603a6fd60a62a1d619ee2696af (patch)
treebef7e8f40d4079c55a8cd0903fccc8f99768f8ab /meson.build
parent949ce2745d9006efab131cf3c447328143f23241 (diff)
turnip: guard -Dvulkan-driver=freedreno
Require -DI-love-half-baked-turnips=true as well to enable freedreno vulkan driver.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 8ec0a56ad30..7a536982da6 100644
--- a/meson.build
+++ b/meson.build
@@ -206,6 +206,10 @@ with_amd_vk = _vulkan_drivers.contains('amd')
with_freedreno_vk = _vulkan_drivers.contains('freedreno')
with_any_vk = _vulkan_drivers.length() != 0 and _vulkan_drivers != ['']
+if with_freedreno_vk and get_option('I-love-half-baked-turnips') != true
+ error('Cannot enable freedreno vulkan driver')
+endif
+
if with_dri_swrast and (with_gallium_softpipe or with_gallium_swr)
error('Only one swrast provider can be built')
endif