aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2018-07-17 15:12:32 +0100
committerEric Engestrom <[email protected]>2018-09-06 18:16:31 +0100
commit3824c8e7cda97c3bf856983ea5fb6d696c75fb24 (patch)
treeb3bde8ef122662af72497ccd0284b66700d47968 /meson.build
parent2930b76cfe1e13e84ac0d88f9c6d709a5a8d4c18 (diff)
meson: disable asserts by default on release builds
By the time Mesa 18.3 comes out (probably December '18), Meson 0.45 will be 9 months old (March '18), so I think this is reasonable. (btw, the currently-required Meson 0.44.1 was released less than 12 days before 0.45, so we're really not bumping by much.) Currently, the Meson versions in the major distributions are: Arch: ships 0.47.2 CentOS: 7 ships 0.47.1 Debian: stable ships 0.37.1, so it hasn't been usable in a long time. everything more recent ships 0.47.2 Fedora: 28 ships 0.45.1 FreeBSD: ships 0.46.1 (ports) Gentoo: ships 0.46.1 OpenSUSE: 15 ships 0.46 Ubuntu: 18.04 ships 0.45.1 Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Dylan Baker <[email protected]>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 909d46a7428..0d534b9b4a9 100644
--- a/meson.build
+++ b/meson.build
@@ -25,8 +25,8 @@ project(
[find_program('python', 'python2', 'python3'), 'bin/meson_get_version.py']
).stdout(),
license : 'MIT',
- meson_version : '>= 0.44.1',
- default_options : ['buildtype=debugoptimized', 'c_std=c99', 'cpp_std=c++11']
+ meson_version : '>= 0.45',
+ default_options : ['buildtype=debugoptimized', 'b_ndebug=if-release', 'c_std=c99', 'cpp_std=c++11']
)
cc = meson.get_compiler('c')