aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJeremy Huddleston <[email protected]>2011-05-05 14:08:57 -0700
committerJeremy Huddleston <[email protected]>2012-01-27 09:05:22 -0800
commite406659b8bed4dd8450935e2f3ee697b99d278cf (patch)
treeb8e303028b01e98f5233b2d0cd1f711054963f08 /configure.ac
parent19f88670b528827f201bba2a996405d230cedc1b (diff)
configure.ac: Don't use $CLANG since it will collide with the static analyzer.
We just prefix the $CLANG environment variable in configure.ac with acv_mesa_ Found by: tinderbox Signed-off-by: Jeremy Huddleston <[email protected]> Reviewed-by: Ian Romanick <[email protected]> (cherry picked from commit b728eefb06c26e4b5a25db31bbda9fcf4d015e17)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 7c50e3c009d..1fcfdbc8caf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -88,13 +88,13 @@ AC_COMPILE_IFELSE(
not clang
#endif
]])],
-[CLANG=yes], [CLANG=no])
+[acv_mesa_CLANG=yes], [acv_mesa_CLANG=no])
-AC_MSG_RESULT([$CLANG])
+AC_MSG_RESULT([$acv_mesa_CLANG])
dnl If we're using GCC, make sure that it is at least version 3.3.0. Older
dnl versions are explictly not supported.
-if test "x$GCC" = xyes -a "x$CLANG" = xno; then
+if test "x$GCC" = xyes -a "x$acv_mesa_CLANG" = xno; then
AC_MSG_CHECKING([whether gcc version is sufficient])
major=0
minor=0