aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <[email protected]>2012-01-11 19:02:26 -0500
committerIan Romanick <[email protected]>2012-05-17 17:20:32 -0700
commitc2fdcc1e12bb636d6533afb49a5d28ba210483e4 (patch)
treede8f601a7b3d8eadbe7efae7f34ee79fbd56043b /configure.ac
parentf1b6c691373a96d537cf408e04192ed48e870100 (diff)
Remove -ffast-math from default CFLAGS
Fixes glsl-const-folding-01. inversesqrt(1.0) != 1.0 was evaluating as true. Signed-off-by: Matt Turner <[email protected]> (cherry picked from commit 2fdbbeca43e7b57095774e4228e6eea75a180fab)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 0 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index ac6007a742d..fbaa37623b5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -168,9 +168,6 @@ esac
dnl Add flags for gcc and g++
if test "x$GCC" = xyes; then
CFLAGS="$CFLAGS -Wall -Wmissing-prototypes -std=c99"
- if test "x$CLANG" = "xno"; then
- CFLAGS="$CFLAGS -ffast-math"
- fi
# Enable -fvisibility=hidden if using a gcc that supports it
save_CFLAGS="$CFLAGS"