aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarek Olšák <[email protected]>2018-03-13 20:22:11 -0400
committerMarek Olšák <[email protected]>2018-03-15 12:44:37 -0400
commit5d0acff39e4274ab803c17855115b231efcbef80 (patch)
treee51a9412761bca0397cb459f005e2dff21535b66 /configure.ac
parent16ecf037f98bab7fa07de664124272096650f65c (diff)
configure.ac: blacklist libdrm 2.4.90
Cc: 18.0 17.3 17.2 <[email protected]> Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 621dc328d90..9b7ae00189a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2608,6 +2608,14 @@ if test -n "$with_gallium_drivers"; then
HAVE_GALLIUM_RADEONSI=yes
PKG_CHECK_MODULES([RADEON], [libdrm >= $LIBDRM_RADEON_REQUIRED libdrm_radeon >= $LIBDRM_RADEON_REQUIRED])
PKG_CHECK_MODULES([AMDGPU], [libdrm >= $LIBDRM_AMDGPU_REQUIRED libdrm_amdgpu >= $LIBDRM_AMDGPU_REQUIRED])
+
+ # Blacklist libdrm_amdgpu 2.4.90 because it causes a crash in older
+ # radeonsi with pretty much any app.
+ libdrm_version=`pkg-config libdrm_amdgpu --modversion`
+ if test "x$libdrm_version" = x2.4.90; then
+ AC_MSG_ERROR([radeonsi can't use libdrm 2.4.90 due to a compatibility issue. Use a newer or older version.])
+ fi
+
require_libdrm "radeonsi"
radeon_llvm_check $LLVM_REQUIRED_RADEONSI "radeonsi"
if test "x$enable_egl" = xyes; then