aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <[email protected]>2017-01-19 15:19:56 +0000
committerEmil Velikov <[email protected]>2017-01-20 14:27:08 +0000
commit5872850b8868f00c031d21387b0516d844d070be (patch)
treedfae483f7e653cc93fc78f8ed1daba9032f29279 /configure.ac
parent383fc8e9f340e80695aca2cd585957af0e081eb9 (diff)
configure.ac: move require_dri_shared_libs_and_glapi() before its users
Otherwise we'll get a lovely message as below: "require_dri_shared_libs_and_glapi: command not found" Cc: Steven Newbury <[email protected]> Reported-by: Steven Newbury <[email protected]> Fixes: da410e6afad "configure: explicitly require shared glapi for enable-dri" Signed-off-by: Emil Velikov <[email protected]> Tested-by: Steven Newbury <[email protected]> Reviewed-by: Nicolai Hähnle <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 16 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index de8af874ecb..64ace9dbcb9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1436,6 +1436,22 @@ if test "x$enable_gallium_osmesa" = xyes; then
fi
fi
+require_dri_shared_libs_and_glapi() {
+ if test "x$enable_static" = xyes; then
+ AC_MSG_ERROR([$1 cannot be build as static library])
+ fi
+
+ if test "x$enable_dri" != xyes; then
+ # There is only a single backend which won't be build/used otherwise.
+ # XXX: Revisit this as the egl/haiku is a thing.
+ AC_MSG_ERROR([$1 requires --enable-dri])
+ fi
+
+ if test "x$enable_shared_glapi" != xyes; then
+ AC_MSG_ERROR([$1 requires --enable-shared-glapi])
+ fi
+}
+
if test "x$enable_dri" = xyes; then
require_dri_shared_libs_and_glapi "DRI"
@@ -1815,22 +1831,6 @@ AC_SUBST([OSMESA_LIB_DEPS])
AC_SUBST([OSMESA_PC_REQ])
AC_SUBST([OSMESA_PC_LIB_PRIV])
-require_dri_shared_libs_and_glapi() {
- if test "x$enable_static" = xyes; then
- AC_MSG_ERROR([$1 cannot be build as static library])
- fi
-
- if test "x$enable_dri" != xyes; then
- # There is only a single backend which won't be build/used otherwise.
- # XXX: Revisit this as the egl/haiku is a thing.
- AC_MSG_ERROR([$1 requires --enable-dri])
- fi
-
- if test "x$enable_shared_glapi" != xyes; then
- AC_MSG_ERROR([$1 requires --enable-shared-glapi])
- fi
-}
-
dnl
dnl gbm configuration
dnl