aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJon TURNEY <[email protected]>2012-07-13 15:14:43 +0100
committerJon TURNEY <[email protected]>2012-07-13 17:20:39 +0100
commit39d82a1b2028a7fe83a885478c9224669ea9f18a (patch)
treec7c4f5f20cb9f13b68fcaedfd3b5ff740d4fc976 /configure.ac
parent9ed65301e044711de0db51b4986085fca170d764 (diff)
Fix linking gallium drivers and with dricore after defadf2b1
Commit defadf2b1 erroneously tries to make gallium drivers link with libdricore as a static library, not a shared library Also, change uses of DRI_LIB_DEPS in gallium driver Makefiles to GALLIUM_DRI_LIB_DEPS, so the libraries added are used in the linking the gallium driver Also, fix the path to the libdricore.so symlink, it's made in LIB_DIR, not in the libdricore directory Also repair quoting of dricore settings of DRI_LIB_DEPS and GALLIUM_DRI_LIB_DEPS variables so VERSION is interpolated in configure but TOP and LIB_DIR are interpolated later (where they are known, but VERSION isn't) Signed-off-by: Jon TURNEY <[email protected]> Signed-off-by: Tom Stellard <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0221c028d41..9227474f13f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1066,8 +1066,8 @@ GALLIUM_DRI_LIB_DEPS='$(TOP)/src/mesa/libmesa.a'
dnl ... or dricore?
if test "x$enable_dri" = xyes && test "x$driglx_direct" = xyes ; then
- DRI_LIB_DEPS='$(TOP)/src/mesa/libdricore/libdricore$(VERSION).la'
- GALLIUM_DRI_LIB_DEPS='$(TOP)/src/mesa/libdricore/libdricore$(VERSION).a'
+ DRI_LIB_DEPS="\$(TOP)/src/mesa/libdricore/libdricore${VERSION}.la"
+ GALLIUM_DRI_LIB_DEPS="\$(TOP)/\$(LIB_DIR)/libdricore${VERSION}.so"
HAVE_DRICORE=yes
fi
AM_CONDITIONAL(HAVE_DRICORE, test x$HAVE_DRICORE = xyes)