aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGurchetan Singh <[email protected]>2016-11-10 12:14:47 -0800
committerEmil Velikov <[email protected]>2016-11-15 15:49:20 +0000
commit0639e253a5fe796e0815ada86086f6e64d1a701a (patch)
tree30631feeb7ea03dbcc66615b6a2cb7818888bf32 /configure.ac
parente23608db1cad3d3b86b5350255db4d47a0081d2e (diff)
egl: Use pkg-config for Android NDK build
It's possible to build Mesa for Android using the traditional autotools workflow [1]. ChromiumOS fetches Android prebuilts and puts them in a sysroot. We now want to use pkg-config to specify the location of system headers and libraries [2]. To enable this, let's add the required pkg-config checks and link against them. [1] https://developer.android.com/ndk/guides/standalone_toolchain.html [2] https://chromium-review.googlesource.com/#/c/403237/ v2: Bundle pkg-config checks together (Emil) v3: Provide further context on standalone NDK Mesa build (Emil) Reviewed-by: Emil Velikov <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3f21cd53a76..9d62b90cfb5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2059,6 +2059,7 @@ for plat in $egl_platforms; do
;;
android)
+ PKG_CHECK_MODULES([ANDROID], [cutils hardware sync])
;;
*)