aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Engestrom <[email protected]>2019-03-14 13:58:54 +0000
committerEric Engestrom <[email protected]>2019-04-04 16:08:11 +0000
commit05b114e5265722e970cb894ed6c3aa3026c0d04d (patch)
tree4f8b97ee38e06c6dfb7117be84dd6e8544b84fbc /configure.ac
parent593614f4d47fbc8aadec6930d7c7c417c46bbd85 (diff)
simplify LLVM version string printing
Figure it out once in the build system, then just use that all over the place. Signed-off-by: Eric Engestrom <[email protected]> Reviewed-by: Marek Olšák <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 78d5967a437..7980493d086 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2936,7 +2936,7 @@ dnl
dnl Set defines and buildtime variables only when using LLVM.
dnl
if test "x$enable_llvm" = xyes; then
- DEFINES="${DEFINES} -DHAVE_LLVM=0x0$LLVM_VERSION_INT -DMESA_LLVM_VERSION_PATCH=$LLVM_VERSION_PATCH"
+ DEFINES="${DEFINES} -DHAVE_LLVM=0x0$LLVM_VERSION_INT -DMESA_LLVM_VERSION_STRING=\\\"$LLVM_VERSION\\\""
LLVM_LDFLAGS=`$LLVM_CONFIG --ldflags`
LLVM_CFLAGS=$LLVM_CPPFLAGS # CPPFLAGS seem to be sufficient