aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSven Gothel <[email protected]>2014-06-10 19:14:45 +0200
committerSven Gothel <[email protected]>2014-06-10 19:14:45 +0200
commita71e2ed35cc57dfc9ca6d33c3a2b8a53b3659710 (patch)
tree0e56f33d3ee7b76bd402cbab0f1d0903793ee685 /CMakeLists.txt
parentf95bf4457fbc31112fa82dacbc1b7e094b9fd1cf (diff)
CMake: Don't use CMAKE_TOOLCHAIN_FILE for non-crosscompilation, use OPENAL_CUSTOM_CONFIG to inject cmake commands
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 217c3d7e..cfbe30c9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -75,6 +75,9 @@ SET(LIB_VERSION "${LIB_MAJOR_VERSION}.${LIB_MINOR_VERSION}.${LIB_REVISION}")
SET(EXPORT_DECL "")
SET(ALIGN_DECL "")
+IF(OPENAL_CUSTOM_CONFIG)
+ include(${OPENAL_CUSTOM_CONFIG})
+ENDIF()
CHECK_TYPE_SIZE("long" SIZEOF_LONG)
CHECK_TYPE_SIZE("long long" SIZEOF_LONG_LONG)