aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2023-02-08 23:06:00 -0800
committerChris Robinson <[email protected]>2023-02-08 23:06:00 -0800
commit8695aa49a5f5d62782217d2380b037d18e7a7460 (patch)
tree2028f77692e1bdb66a20d46e5a2b14cdcbb33ee9 /CMakeLists.txt
parent233d3f8d15681c62ba18940440ceabe5913cff61 (diff)
Check for the existence of the file that's depended on
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c37fe0b6..92cc138a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1206,7 +1206,7 @@ set(BACKENDS "${BACKENDS} Null")
find_package(Git)
-if(ALSOFT_UPDATE_BUILD_VERSION AND GIT_FOUND AND EXISTS "${OpenAL_SOURCE_DIR}/.git")
+if(ALSOFT_UPDATE_BUILD_VERSION AND GIT_FOUND AND EXISTS "${OpenAL_SOURCE_DIR}/.git/index")
# Get the current working branch and its latest abbreviated commit hash
add_custom_command(OUTPUT "${OpenAL_BINARY_DIR}/version_witness.txt"
BYPRODUCTS "${OpenAL_BINARY_DIR}/version.h"