aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2023-12-13 22:18:09 -0800
committerChris Robinson <[email protected]>2023-12-13 22:18:09 -0800
commit760ada93e88d3c78f6613b52eb5ef15c1564ad80 (patch)
treee3aebec8d8a4c509163d4a155c525c8c0248ef01 /CMakeLists.txt
parent70b3776032adf05a92fda89ac5f56eb705d06748 (diff)
Fix clang-tidy warnings from the examples and utilities
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ce287ba0..59c0711e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1339,7 +1339,8 @@ configure_file(
add_library(alcommon STATIC EXCLUDE_FROM_ALL ${COMMON_OBJS})
-target_include_directories(alcommon PRIVATE ${OpenAL_BINARY_DIR} ${OpenAL_SOURCE_DIR}/include)
+target_include_directories(alcommon PRIVATE ${OpenAL_BINARY_DIR} ${OpenAL_SOURCE_DIR}/include
+ PUBLIC ${OpenAL_SOURCE_DIR}/common)
target_compile_definitions(alcommon PRIVATE ${CPP_DEFS})
target_compile_options(alcommon PRIVATE ${C_FLAGS})
set_target_properties(alcommon PROPERTIES ${DEFAULT_TARGET_PROPS} POSITION_INDEPENDENT_CODE TRUE)